You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

128 lines
2.3 KiB

# Copyright 2017-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Auto-Generated by cargo-ebuild 0.3.1
EAPI=7
CRATES="
addr2line-0.13.0
adler-0.2.3
aho-corasick-0.7.13
atty-0.2.14
autocfg-1.0.1
backtrace-0.3.51
bitflags-1.2.1
block-buffer-0.9.0
bytes-0.5.6
cfg-if-0.1.10
color-eyre-0.5.6
cpuid-bool-0.1.2
digest-0.9.0
env_logger-0.7.1
eyre-0.6.1
fnv-1.0.7
fuchsia-zircon-0.3.3
fuchsia-zircon-sys-0.3.3
futures-0.3.6
futures-channel-0.3.6
futures-core-0.3.6
futures-executor-0.3.6
futures-io-0.3.6
futures-macro-0.3.6
futures-sink-0.3.6
futures-task-0.3.6
futures-util-0.3.6
generic-array-0.14.4
getrandom-0.1.15
gimli-0.22.0
hermit-abi-0.1.16
humantime-1.3.0
indenter-0.3.0
iovec-0.1.4
kernel32-sys-0.2.2
lazy_static-1.4.0
libc-0.2.78
log-0.4.11
memchr-2.3.3
miniz_oxide-0.4.2
mio-0.6.22
miow-0.2.1
net2-0.2.35
num_cpus-1.13.0
object-0.20.0
once_cell-1.4.1
opaque-debug-0.3.0
owo-colors-1.1.3
pin-project-0.4.26
pin-project-internal-0.4.26
pin-project-lite-0.1.10
pin-utils-0.1.0
ppv-lite86-0.2.9
pretty_env_logger-0.4.0
proc-macro-hack-0.5.18
proc-macro-nested-0.1.6
proc-macro2-1.0.24
quick-error-1.2.3
quote-1.0.7
rand-0.7.3
rand_chacha-0.2.2
rand_core-0.5.1
rand_hc-0.2.0
recolored-1.9.3
regex-1.3.9
regex-syntax-0.6.18
rustc-demangle-0.1.16
rustc_version-0.2.3
semver-0.9.0
semver-parser-0.7.0
sha2-0.9.1
slab-0.4.2
syn-1.0.42
termcolor-1.1.0
thread_local-1.0.1
tokio-0.2.22
tokio-macros-0.2.5
typenum-1.12.0
unicode-xid-0.2.1
uuid-0.8.1
version_check-0.9.2
wasi-0.9.0+wasi-snapshot-preview1
winapi-0.2.8
winapi-0.3.9
winapi-build-0.1.1
winapi-i686-pc-windows-gnu-0.4.0
winapi-util-0.1.5
winapi-x86_64-pc-windows-gnu-0.4.0
ws2_32-sys-0.2.1
"
inherit cargo
DESCRIPTION="Coerce hardlinks into new files"
# Double check the homepage as the cargo_metadata crate
# does not provide this value so instead repository is used
HOMEPAGE="https://git.flanchan.moe/flanchan/sever"
SRC_URI="$(cargo_crate_uris ${CRATES} sever-1.1.2)"
RESTRICT="mirror"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+parallel +limit-concurrency +splash +recursive +limit-recursion threads paranoid-dedup"
DEPEND=""
RDEPEND=""
src_configure() {
local myfeatures=(
$(usev parallel)
$(usev limit-concurrency)
$(usev splash)
$(usev recursive)
$(usev limit-recursion)
$(usev threads)
$(usev paranoid-dedup)
)
cargo_src_configure --no-default-features
}